Adobe Flash Player 9 pour GNU/Linux !

Comme je l'ai souligné à maintes reprises, je n'ai jamais été un grand fan de Flash (Flashblock est mon meilleur ami ;-) ), pour plusieurs raisons. Malgrès cela, il m'arrive de temps en temps d'avoir besoin de visionner certaines animations, qui ne fonctionnent qu'avec les versions récentes de Flash Player.

Flash Player 9 pour Linux Alors qu'Adobe améliorait la version pour Windows de Flash Player, la version GNU/Linux était presque délaissée. En effet, elle n'a pas bougé depuis la version 7, c'est-à-dire depuis 2004!

La seule solution était de faire fonctionner la version Windows de certains navigateurs (Internet Explorer 6, Firefox) sous GNU/Linux, en utilisant un émulateur, chose qui n'était pas du tout pratique :-(

Dorénavant, toute cette histoire appartient au passé puisqu'Adobe vient de sortir Flash Player 9 pour GNU/Linux!

Avant de l'installer...

Il faut savoir que la version actuellement disponible est encore en phase de test (bêta). Quelques bugs (ou fonctionnalités manquantes), pas bien graves, persistent encore, par exemple :

  • Ne fonctionne que partiellement avec Opera
  • Le mode plein écran pas encore intégré
  • Pas de support SSL
  • Petits soucis avec le menu contextuel
  • Les polices peuvent être différentes, selon la distribution

Installer la nouvelle version

Ubuntu

Je vous invite à télécharger le paquet :

(je remercie Lost In Brittany pour l'info)

Vous pouvez l'installer soit d'une manière graphique, en double-cliquant dessus, soit en utilisant la ligne de commande :

sudo dpkg -i flashplugin-nonfree_9.0.21.55-3v1ubuntu0_i386.deb

Arch Linux

Éditez le fichier /etc/pacman.conf, en tant que root, puis activez le dépôt unstable, en ajoutant ces lignes:

[unstable]
Include = /etc/pacman.d/unstable

Après cela, lancez l'installation du plugin avec la commande :

pacman -Sy unstable/flashplugin-beta

Installation manuelle

Rendez-vous dans cette page, cliquez sur Download Installer for Linux pour télécharger le fichier FP9_plugin_beta_101806.tar.gz.

Déplacez vous vers le répertoire qui contient l'archive FP9_plugin_beta_101806.tar.gz:

cd repertoire

Décompressez l'archive:

tar xvf FP9_plugin_beta_101806.tar.gz

Entrez dans le nouveau répertoire:

cd flash-player-plugin-9.0.21.55

Créez le répertoire des plugins de votre utilisateur:

mkdir -p $HOME/.mozilla/plugins

Copiez le plugin:

cp libflashplayer.so $HOME/.mozilla/plugins

C'est tout. Il vous suffit de redémarrer votre navigateur pour profiter des nouveautés de la version 9!

Quelques liens

Cette nouvelle a fait beaucoup d'echo. J'ai sélectionné pour vous quelques articles qui traitent le même sujet:

Commentaires

1. Le vendredi, octobre 20 2006, 01:40 par antistress

merki!

2. Le vendredi, octobre 20 2006, 08:06 par farf

J'ai tenté le trackback mais ça n'a pas fonctionné. Pas grave. Quoi qu'il en soit, merci de l'info

3. Le vendredi, octobre 20 2006, 11:47 par Gilles

Juste un bémol, le plugin fonctionne sous Opera, mais il ne fonctionne que partiellement. Certains sites tournent sans problème, tandis que d'autres font planter le navigateur.

4. Le vendredi, octobre 20 2006, 15:22 par Asher256

@farf: Pour le trackback, l'url est automatiquement invalide après un certain temps. Essaye une nouvelle fois, en faisant vite :-D (anti spam).

@Gilles: Merci pour l'info, le billet vient d'être mis à jour ;-)

5. Le lundi, octobre 23 2006, 20:23 par Sinan

C'est marrant j'avais écrit à adobe pour une maj de flahs palyer il y a plusieurs mois^^

6. Le samedi, octobre 28 2006, 08:25 par Fabrice

Merci :)
Je l'ai installé sans aucun problème. Je n'ai plus les messages d'erreurs sur certains sites 'Flash player trop ancien' ;)

7. Le jeudi, janvier 4 2007, 02:11 par G-rom

c'est normal si apres l'installation manuel ça ne marche toujours pas ?? ça vient du faire que je suis sur un noyau 64bit ??

8. Le mercredi, janvier 10 2007, 19:00 par AppTeF

Pas mieux, ça marche pas en 64bit !

9. Le dimanche, février 25 2007, 12:39 par mael

svp aidez moi a installer adobe flah player 9 parce que j'ai installer un jeu qui s'apelle dofus et j'aimerai bien pouvoir y jouer mais je ne sais pas si cela vient de mon ordinateur et je n'ai que 11 ans donc svp si vous pouviez repondre a cette aide que j'ai demander .merci (repodez vite bien expliquer svp)

10. Le dimanche, mai 13 2007, 13:00 par nice

Depuis que j'ai installé flash player 9, mon firefox 2.0.0.1 plante régulièrement...
Je e sait pas si c'est a config qui est en cause, mais pour moi ce n'est pas le genre de bug mineur.

11. Le dimanche, mai 13 2007, 22:14 par tawfik

j'ai télécgarger le jeux dofus mais il veut pas marcher!!il demande une version dadobe qur j'ai pas trouvé:adobe flash player1.18.1(build4203)
S'il vous plait si quelq'un peut m'aider!!

12. Le mercredi, septembre 3 2008, 14:38 par dracula

diser moi comment installer le flash je ne trouve pas

La discussion continue ailleurs

1. Le vendredi, octobre 20 2006, 02:28 par devloop :: blog

Flash 9 pour Linux : c'est parti !!!

La nouvelle est tombé il y a moins d'une heure par un billet sur Penguin.SWF, le blog du principal développeur du plugin flash pour Linux : une version béta de Flash 9 est téléchargeable ! Il n'y a pas si longtemps une démonstration avait été...

2. Le vendredi, octobre 20 2006, 09:01 par Biologeek : Ubuntu, bio-informatique et geekeries libres d'un bio-informaticien au quotidien.

Enfin flash 9 pour Linux !

On l'attendait depuis tellement longtemps que ça devenait presque une légende mais les dev Adobe ont fait du bon boulot sur ce coup là. Procédure d'installation pour Ubuntu...

3. Le vendredi, octobre 20 2006, 13:20 par L'autre terrier de Bouledepoil

Flash 9 est enfin disponible sous Linux

Après 2 ans d'attente (Flash 7 Linux date de 2004) et 2 versions de retard par rapport aux utilisateurs Windows (Flash 9 Windows est disponible depuis quelques temps déjà), la version 9 du Flash Player est enfin disponible sous GNU/Linux.

4. Le samedi, octobre 21 2006, 11:53 par Le blog de Lalain

Enfin du flash

Les linuxiens ont enfin la possibilité d'installer une nouvelle version de flash, la beta de la version 9. Il faut savoir que adobe n'a pas sorti de version 8 de flash et nous sommes donc resté avec la version 7 trop longtemps, beaucoup de sites...

5. Le samedi, octobre 21 2006, 12:35 par Le blog de Nicosmos

Sorties

Une première bêta de Flash Player 9 pour Linux est enfin disponible ...

6. Le samedi, octobre 28 2006, 16:11 par HECHT Franck Blog's

Installation de Flash Player 9 sous Linux Ubuntu !

Sortie il y'a environ une semaine en téléchargement, la nouvelle version de Flash Player est enfin disponible pour Linux après deux ans de mise en attente de ce player sous en version GNU/Linux ! Le blog Asher256's Blog nous propose...

7. Le jeudi, novembre 16 2006, 20:11 par Leonel's blog

Adieu Mandriva, Bonjour Ubuntu !

Linuxien dans l'âme (je ne m'y suis jamais plongé à 100% sans double boot avec Windows) depuis la découverte de ce système d'exploitation (un CD de Knoppix dans un magazine il ya 4 ou 5 ans), j'ai toujours utilisé Mandrake (puis Mandriva) car elle...